Monday, 2018-11-12, 11:58 PM
[ New messages · Members · Forum rules · Search · RSS ]
  • Page 1 of 1
  • 1
Forum » Forum » Bug Report » MacOS incompatibility (The latest versions don't start on the legal MacOS WC3.)
MacOS incompatibility
bjeaurnFecha: Sunday, 2017-11-26, 12:23 PM | Mensaje # 1
Private
Group: User
Message: 1
Reputation: 0
Status: Offline
Hey,

We've noticed that the latest version of the game, including a couple of the previous ones, seem to be incompatible with MacOS's latest legal update (1.28.5.7680) that brings back native support for the game. 

When loading up the map as host; it starts with the map description saying: "This file could not be found on your computer.". After trying to load it anyway it gets "There was an error trying to load the selected map, blabla unavailable blabla or corrupted."

When I use my Windows machine to host, it runs fine; the MacOS machines cannot join; they get instantly kicked. 

When I host an older version, like 1.17F they can join but the experience still is not stable as one of the clients crashed as soon as we opened up the Hero selection building.

Is this something you've seen before? Seems like there's an incompatiblity with the different versions of the game, that version wise should be alike!

Any clues what's wrong and what it would take to reach a potential fix?

Thanks!
Alex0013Fecha: Monday, 2017-11-27, 0:38 AM | Mensaje # 2
Colonel
Group: User
Message: 216
Reputation: 2
Status: Offline
MacOS has always been unstable on many custom maps. I even have friends that can't play on a Windows VM on a Mac, he must dual-boot and load up Windows else he crashes.

I would recommend just always playing Windows. Blizzard can try to make Mac compatible with a Windows-based game, but imo, it'll never be very stable unless they try a lot harder wink
Forum » Forum » Bug Report » MacOS incompatibility (The latest versions don't start on the legal MacOS WC3.)
  • Page 1 of 1
  • 1
Search: